Access to App and Exchange services - UK customers on BT broadband
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 19, 2021 - 20:23 HKT
Update
We are continuing to investigate this issue.
Posted May 30, 2021 - 11:40 HKT
Update
We are continuing to investigate this issue.
Posted May 28, 2021 - 19:00 HKT
Investigating
We are aware of issues accessing the App and Exchange services reported by UK customers who use BT broadband services. Further investigations are ongoing.
Posted May 28, 2021 - 18:58 HKT
This incident affected: Crypto.com App Wallet (Buy, Sell, Send, Withdrawals, Deposits, Fiat Wallets), Crypto.com App (Main Page, Track Coins, Notifications, Onboarding, Card and Staking), and Crypto.com Exchange (Spot/Derivatives) (API Server - Spot/Margin, API Server - Derivatives, Web Server - Spot/Margin, Web Server - Derivatives, Withdrawals, Deposits).