BTC Withdrawals Impacted
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 19:34 HKT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 23, 2020 - 11:07 HKT
Update
We are continuing to investigate this issue.
Posted Jun 23, 2020 - 07:41 HKT
Investigating
BTC withdrawals are experiencing issues due to internal system performance issues. We are working hard to resolve it.
Posted Jun 23, 2020 - 07:40 HKT
This incident affected: Crypto.com Exchange (Withdrawals) and Crypto.com App Wallet (Withdrawals).