Issue with stocks and shares screen list

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted 4 months ago. Jan 11, 2025 - 17:40 HKT

Investigating

We are currently having some issues with the stocks and shares screen, only top 10 gainers / loser market cap data is available. Please wait whilst we are fixing this on highest priority. Thank you for your understanding.
Posted 4 months ago. Jan 11, 2025 - 14:27 HKT