$EGLD Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 03, 2021 - 01:07 HKT
Monitoring
Crypto.com is supporting @ElrondNetwork’s mainnet upgrade.

$EGLD deposits/withdrawals will be temporarily suspended in the App and Exchange at 13:00 UTC on 2 November 2021.

Trading of $EGLD will not be affected.

Details: https://blog.crypto.com/crypto-com-supports-elronds-mainnet-upgrade
Posted Nov 02, 2021 - 20:00 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).