App slowness
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 22:01 HKT
Update
This issue seems to be related to an upstream service provider for routes specifically between customers in EU and our data centers. Other regions are unaffected.

We are working closely with our partners on this. We appreciate your patience on this matter.
Posted Aug 11, 2022 - 20:57 HKT
Investigating
We are aware the app is experiencing slowness. The team is working on this as top priority.
Posted Aug 11, 2022 - 20:10 HKT
This incident affected: Crypto.com App (Main Page, Track Coins, Notifications) and Crypto.com App Wallet (Buy, Sell, Send, Withdrawals, Deposits, Fiat Wallets).