Flow Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 18:30 HKT
Update
We are continuing to investigate this issue.
Posted Apr 21, 2021 - 11:19 HKT
Investigating
Flow deposits/withdrawals are delayed. We are currently investigating this issue.
Posted Apr 09, 2021 - 20:53 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).