EUR Fiat Wallet Deposits and Withdrawals
Incident Report for Crypto.com
Resolved
The migration of our EUR Fiat Wallet to a new provider is complete. The majority of users have had their EUR Fiat Wallet services (deposit/withdrawal) restored, and have been notified via email. If you are among the few users who do not yet have your EUR Fiat Wallet services restored, please watch out for further instructions by email.
Posted Jan 25, 2023 - 14:35 HKT
Identified
We are in the process of migrating our EUR Fiat Wallet to a new provider and estimate this transition to be complete in approximately 72 hours. For this reason, EUR Fiat Wallet deposits and withdrawals will be temporarily disabled during this time.

Users can continue to use their EUR balances to buy/sell crypto and use other services, including depositing and withdrawing crypto. Additionally, users can continue to transfer EUR balances to their Crypto.com Visa Card to use anywhere Visa is accepted, including EUR withdrawal at ATMs. During the transition, we are waiving crypto purchase fees with debit card for impacted users in EEA countries and Switzerland.
Posted Jan 22, 2023 - 15:45 HKT