Crypto withdrawal delayed processing
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 18:51 HKT
Identified
We are aware of prolonged withdrawal processing times affecting both Crypto.com App wallet and Exchange users. The issue has been identified and we are working to resolve it as soon as possible.
Posted Oct 13, 2021 - 13:21 HKT
This incident affected: Crypto.com App Wallet (Withdrawals), Crypto.com Exchange (Spot/Derivatives) (Withdrawals), and NFT (NFT Withdraw).