Crypto.com Exchange - Users with Balances Stuck "In Order"
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 16:07 HKT
Monitoring
Please reach out to our Customer Service team if you believe you have balances stuck "in order" on the Crypto.com Exchange
Posted Oct 07, 2021 - 11:49 HKT
Investigating
We are aware of some users who have balances stuck "in order". We are working to resolve this as quickly as possible. We apologize for the inconvenience
Posted Oct 07, 2021 - 04:16 HKT