Performance Issues with User Signup on Crypto.com Main App
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 24, 2024 - 14:45 HKT
Investigating
We are currently experiencing some performance issues relating to new user sign up for Crypto.com Main app. Our teams are currently working on it.
Posted Aug 24, 2024 - 13:58 HKT