XTZ Deposits Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 19, 2020 - 19:10 HKT
Investigating
XTZ deposits are delayed. We are currently investigating this issue.
Posted Aug 19, 2020 - 18:13 HKT
This incident affected: Crypto.com App Wallet (Deposits) and Crypto.com Exchange (Spot/Derivatives) (Deposits).