Intermittent Issues with new user logins

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 22:35 HKT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 22:11 HKT

Identified

We are currently aware of some users unable to initiate new logins to our products due to Cloudflare outage.

- Crypto.com Main app
- Crypto.com Web
- Crypto.com Exchange

We are working on this at the highest priority.
Please retry with alternative method logins such as QR code/ Passkey / email if possible.
Posted Nov 18, 2025 - 21:58 HKT