Crypto.com Main App Android Users onchain unstake issues

Incident Report for Crypto.com

Update

Our fix have been developed, it will be included in the next app version 3.219.11 - ETA 24th Oct.
Posted Oct 23, 2025 - 18:23 HKT

Update

Apologies this is taking longer than we had originally expected, the new ETA for the fix will be 23 Oct 2025.
Posted Oct 22, 2025 - 15:33 HKT

Identified

We have identified an issue with current version of Crypto.com Main app 3.219.10, where if users try to unstake they will get an error.

The issue will be fixed on 22 Oct 2025.

Sorry for the inconveniences caused.
Posted Oct 21, 2025 - 18:44 HKT