Stock and ETF maintenance

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:54 HKT

Investigating

Please be informed that stock and ETF trading is currently undergoing maintenance in the Crypto.com App .

During this period, new orders and cash withdrawals will be paused.

Other services will not be impacted.
Posted Jun 13, 2025 - 04:13 HKT