Cronos Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 08:17 HKT
Investigating
Withdrawals to Cronos are delayed. We are currently investigating this issue.
Posted Nov 25, 2021 - 00:03 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals) and Crypto.com App Wallet (Withdrawals).