1099-DA form unable to be downloaded

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 05:42 HKT

Investigating

We are currently experiencing an issue with 1099-DA forms downloading as expected from our Tax site https://crypto.com/1099form/download. Services will resume once these issues are resolved.
Posted Feb 20, 2026 - 03:29 HKT