GALA Token Features Paused
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 11:12 HKT
Monitoring
GALA token features including trading, deposits and withdrawals are currently paused
Posted Nov 13, 2022 - 07:09 HKT