Crypto Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 07, 2020 - 01:31 HKT
Investigating
Crypto deposits/withdrawals are delayed. We are currently investigating this issue.
Posted Sep 06, 2020 - 21:29 HKT
This incident affected: Crypto.com Exchange (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).