BSC Network Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 07, 2021 - 13:36 HKT
Monitoring
BSC Network deposits/withdrawals are delayed. We are currently monitoring this issue.
Posted Nov 03, 2021 - 20:03 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).