Issue with US related activities in Crypto.com Main app and Crypto.com Web
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 20:03 HKT
Investigating
We are currently having some issues with the Crypto.com main app, for US users, these features are currently slow or unavailable:

- Derivatives Trading
- Sports Prediction
- Stocks and Shares
Posted Jan 15, 2025 - 19:37 HKT