App Slowness and Exchange Login Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 17:06 HKT
Investigating
We are investigating and working on resolving this as soon as possible
Posted Jan 08, 2021 - 16:23 HKT
This incident affected: Crypto.com App (Main Page) and Crypto.com Exchange (Web Server).