ERD Trading Impacted
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 20:42 HKT
Identified
ERD buying and selling is temporarily suspended due to an ongoing ERD Mainnet swap.

We appreciate your patience and will update this page as soon as the situation changes.
Posted Aug 31, 2020 - 22:32 HKT
This incident affected: Crypto.com App Wallet (Buy, Sell).