Sports and Leverage Tabs taking too long to load
Incident Report for Crypto.com
Resolved
The issue was identified and fixes were implemented. Sport and Leverage tab loading normally.
Posted Jan 20, 2025 - 10:46 HKT
Investigating
We are currently experiencing some issues with Sports and Leverage tabs. Our teams are looking into this issue at the highest urgency. We appreciate your patience and will keep you posted once there is an update.
Posted Jan 20, 2025 - 10:26 HKT