StraitsX (Xfers) Wallet under Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 07, 2022 - 01:33 HKT
Investigating
We are currently under system maintenance for the Straits (Xfers) from 23:59 HKT (15:59 UTC) on 6 th Oct 2022. The maintenance is expected to take approximately 1.5 hours, but may vary depending on the circumstances on the day.
Posted Oct 06, 2022 - 23:53 HKT
This incident affected: Crypto.com App Wallet (Fiat Wallets).