Intermittent Issue with Exchange Web and App

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Sep 06, 2024 - 16:46 HKT

Investigating

We are experiencing some intermittent issues with Exchange Web and App

Our teams are looking into this issue with the highest urgency. We appreciate your patience and will keep you posted once there is any update.
Posted Sep 06, 2024 - 16:26 HKT