Issues with SCB USD SWIFT Singapore Deposits / Withdrawals

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 20:41 HKT

Investigating

We are currently experiencing a temporary interruption affecting USD international transfers for Singapore users. Our teams are actively working to restore the service.

We apologize for any inconvenience and thank you for your patience.
Posted Mar 24, 2025 - 19:45 HKT