$RUNE Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 20, 2021 - 19:09 HKT
Monitoring
$RUNE deposits/withdrawals are delayed. We are currently investigating this issue.
Posted Nov 13, 2021 - 14:53 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).