Email Notification Delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 10:14 HKT
Investigating
We are aware of an intermittent issue with emails being delayed. We are working with our partners on this. Thank you for your patience.
Posted Oct 05, 2021 - 09:21 HKT
This incident affected: Crypto.com App (Notifications).