Exchange App sign up issue

Incident Report for Crypto.com

Resolved

Sign up via exchange app is resumed
Posted Nov 04, 2025 - 13:27 HKT

Investigating

Please note exchange app sign up flow is blocked due to Recaptcha issues. Our team is working on the fix urgently.
Posted Nov 04, 2025 - 12:04 HKT