Inaccurate log of deposit in the transaction history of the USD Fiat wallet
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 07, 2021 - 15:37 HKT
Investigating
We're currently investigating inaccurate log of deposit(s) in the transaction history of the USD Fiat wallet

Thank you for your patience
Posted May 03, 2021 - 16:44 HKT
This incident affected: Crypto.com App Wallet (Fiat Wallets).