Some users unable to see their Crypto.com Main app wallet balance

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 15, 2024 - 18:33 HKT

Investigating

We have identified an issue where some users are unable to see their Crypto.com Main app wallet balance.

Please be assured your balance is not affected, we're working on this at the highest priority.
Posted Nov 15, 2024 - 18:11 HKT