$ICX Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 04, 2021 - 13:19 HKT
Monitoring
Crypto.com is supporting @helloiconworld’s network upgrade.

$ICX deposits/withdrawals will be temporarily suspended in the App and Exchange at 12:00 UTC on 3 November 2021.

Trading of $ICX will not be affected.

Details: https://blog.crypto.com/crypto-com-supports-icon-foundations-network-upgrade
Posted Nov 03, 2021 - 20:05 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).