BCH Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 08:17 HKT
Investigating
Crypto.com is supporting the Bitcoin Cash Network Upgrade on 15 Nov 2020.
Please note that there will be a temporary suspension of #BCH deposits/withdrawals on our App & Exchange at 10:00 UTC on 15 Nov 2020.
Posted Nov 15, 2020 - 18:10 HKT
This incident affected: Crypto.com Exchange (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).