Slow Crypto Deposits
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Dec 01, 2024 - 18:24 HKT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2024 - 17:25 HKT
Investigating
We are aware of the issue and is currently working at the highest priority. Please be assured your deposits will be credited very soon.
Posted Dec 01, 2024 - 16:20 HKT