Litecoin (LTC) Deposits Temporarily Suspended

Incident Report for Crypto.com

Resolved

This incident has been resolved and LTC deposit features have been reestablished.
Posted Apr 26, 2026 - 09:51 HKT

Investigating

We are temporarily suspending Litecoin (LTC) deposits on Crypto.com App and Exchange while we monitor a developing situation on the Litecoin network. This is a precautionary measure to protect our users.

We are actively monitoring the situation and will restore deposit functionality as soon as it is safe to do so. We apologize for any inconvenience and will provide further updates here.
Posted Apr 26, 2026 - 09:05 HKT