All Withdrawals Paused
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 10:07 HKT
Investigating
Withdrawals service is currently undergoing unscheduled maintenance. Thank you for your patience.
Posted Dec 22, 2020 - 06:07 HKT
This incident affected: Crypto.com Exchange (Withdrawals) and Crypto.com App Wallet (Withdrawals).