Card transactions normal but reflections onto Crypto.com app might be delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 17:22 HKT
Investigating
We are aware users are not seeing their card screen being updated. However your card will work fine with merchants, you will still be able to load your card and fiat wallets. Our team is working to resolve this with the highest priority, thank you for your patience.
Posted Oct 28, 2021 - 09:32 HKT