Issues in adding wallet addresses for withdraws (Main App Wallet and Exchange)

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 22:47 HKT

Investigating

We are aware of an issue affecting some users who are experiencing problems when attempting to whitelist addresses for withdrawals on the Crypto.com Main App and Exchange.

Our team is actively working to resolve this as a top priority.
Posted Sep 23, 2025 - 22:23 HKT