USD Fiat Wallet Vendor Greendot Scheduled Maintenance

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 09, 2025 - 15:22 HKT

Investigating

Our USD fiat wallet vendor "Greendot" will be undergoing scheduled maintenance from 9:30 PM PT on October 25, 2025 to 11:00 PM PT on Nov 8, 2025.

Impact:
- Cash account creation, deposit, withdrawal will be temporarily unavailable during this period


We apologize for any inconvenience and appreciate your patience during this maintenance window.
Posted Nov 09, 2025 - 13:21 HKT