ETH/ERC20 Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 20, 2021 - 08:53 HKT
Investigating
ETH/ERC20 token withdrawals are delayed due to network congestion.
Posted May 19, 2021 - 22:45 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).