Crypto Withdrawals Delayed and Credit Card Transactions Affected

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jun 05, 2020 - 10:55 HKT

Identified

Crypto withdrawals will be delayed and credit card transactions for crypto purchases and card topups will be impacted.

We are working on the issue with our partners, and apologize for the inconvenience.
Posted Jun 05, 2020 - 08:14 HKT
This incident affected: Crypto.com App/Web Wallet (Buy, Withdrawals) and Crypto.com Exchange (Spot/Derivatives) (Withdrawals).