ETH and ERC20 Deposits Temporarily Suspended
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 19:45 HKT
Update
Withdrawals have been re-enabled. Deposits are still in progress. Thank you for your patience
Posted Nov 11, 2020 - 18:49 HKT
Update
This is related to the Ethereum network infrastructure issue
Posted Nov 11, 2020 - 17:31 HKT
Investigating
ETH and ERC20 Deposits and Withdrawals have been temporarily suspended
Posted Nov 11, 2020 - 17:29 HKT
This incident affected: Crypto.com Exchange (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).