Performance issue - Email, SMS, Support Chat, Plaid (US cash account)

Incident Report for Crypto.com

Resolved

Email, SMS, Support Chat, Plaid (US cash account) services are back to normal
Posted Oct 20, 2025 - 18:17 HKT

Identified

The SMS OTP service is now up and running.
Users can still log in with passkey, and logged-in users remain unaffected.
Posted Oct 20, 2025 - 16:47 HKT

Investigating

Team is actively checking with upstream & downstream vendors and will keep you posted once there is an update
Posted Oct 20, 2025 - 16:16 HKT