ADA Withdrawals Impacted
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 15, 2020 - 03:32 HKT
Identified
ADA withdrawals are currently experiencing issues, and our team is working to resolve this promptly.

Thank you for your patience.
Posted Aug 14, 2020 - 07:48 HKT
This incident affected: Crypto.com Exchange (Withdrawals) and Crypto.com App Wallet (Withdrawals).