App Slowness and Exchange Login Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 05:02 HKT
Investigating
We are investigating and working on resolving this as soon as possible.
Posted Feb 18, 2021 - 04:11 HKT
This incident affected: Crypto.com App (Main Page) and Crypto.com Exchange (Spot/Derivatives) (Web Server).