FLR Staking Temporarily Suspended

Incident Report for Crypto.com

Monitoring

Please note FLR staking in US and Canada have recovered. For other regions, the service should recover on Feb 11th.
Posted Feb 05, 2026 - 13:24 HKT

Investigating

Please be advised that staking for FLR is currently suspended.
Unstaking services remain fully operational and are unaffected.
Estimated Resolution: February 5, 2026
Posted Jan 27, 2026 - 18:43 HKT