Exchange Orders Stuck In Balance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 20, 2020 - 10:22 HKT
Identified
We've identified an issue that occurred at roughly 21:30 UTC on 19 Aug 2020 that may have caused orders to be stuck in the 'Order Balance'. Our teams are working to correct this as soon as possible, and we apologize for the inconvenience.
Posted Aug 20, 2020 - 07:40 HKT