Tax Sign up Issue
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Dec 30, 2021 - 10:21 HKT
Investigating
We are seeing an issue where the “Select Nationality” dropdown menu is unresponsive when users click the field. Signup will be temporarily unavailable. Our team is working on urgently resolving this. Thank you for your patience.
Posted Dec 30, 2021 - 09:55 HKT
This incident affected: TAX (Website).