Native CRO Withdrawals Slow
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Mar 27, 2021 - 18:00 HKT
Investigating
We are aware of the issue that native CRO withdrawals are slow. We are working hard on resolving this issue.
Posted Mar 26, 2021 - 20:06 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals) and Crypto.com App Wallet (Withdrawals).