Exchange BAND withdrawals temporarily disabled
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 19:55 HKT
Identified
Exchange BAND withdrawals are temporarily disabled while we investigate an issue causing withdrawal delays
Posted Oct 08, 2020 - 16:34 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals).